If you are using version 48.0.2 of Mozilla Fire Fox please do not accept their updates we have found that it is not compatible with Zoom Text, we will let you know when it is compatible some functions  will work much of this really depends on your needs and the sites that you are on I can say for sure it has issues with Net flicks.

 

 

 

 

Leave a Reply